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PREFACE

The Regional Initiative for the Assessment of Climate Change Impacts on Water Resources and Socio-Economic Vulnerability in 
the Arab Region (RICCAR) is a joint initiative of the United Nations and the League of Arab States launched in 2010.

RICCAR is implemented through a collaborative partnership involving 11 regional and specialized organizations, namely the 
United Nations Economic and Social Commission for Western Asia (ESCWA), the Arab Center for the Studies of Arid Zones and 
Dry Lands (ACSAD), Food and Agriculture Organization of the United Nations (FAO), Deutsche Gesellschaft für Internationale 
Zusammenarbeit (GIZ), the League of Arab States, Swedish Meteorological and Hydrological Institute (SMHI), United Nations 
Environment Programme (UN Environment), United Nations Educational, Scientific and Cultural Organization (UNESCO) Office 
in Cairo, United Nations Office for Disaster Risk Reduction (UNISDR), United Nations University Institute for Water, Environment 
and Health (UNU-INWEH), and World Meteorological Organization (WMO). ESCWA coordinates the regional initiative. Funding 
for RICCAR is provided by the Government of Sweden and the Government of the Federal Republic of Germany.

RICCAR is implemented under the auspices of the Arab Ministerial Water Council and derives its mandate from resolutions 
adopted by this council as well as the Council of Arab Ministers Responsible for the Environment, the Arab Permanent 
Committee for Meteorology and the 25th ESCWA Ministerial Session.

Funding for this report was provided by the Swedish Government through the Swedish International Development Cooperation 
Agency.

This manual was prepared by ESCWA and ACSAD. An Arabic version of this report with supplementary exercises is available as 
E/ESCWA/SDPD/2019/GUIDE.4



iv

TRAINING MANUAL ON THE USE OF GIS TO ANALYSE CLIMATE CHANGE DATA

iv

CONTENTS

PREFACE												            iii

ACRONYMS AND ABBREVIATIONS									         vii

1	 INTRODUCTION										          1

2	 SUMMARY OF RICCAR CLIMATE CHANGE DATA						      1

3	 ARCMAP MULTIDIMENSION TOOL								        5
3.1	 Introduction to NetCDF format								        5
3.2	 Create raster files from NetCDF files								        6
3.3	 Create tables from NetCDF files								        16

4	 CREATING ENSEMBLES USING SPATIAL ANALYST TOOLS					     25
4.1	 Calculating annual and seasonal projections							       25
4.2	 Comparing projections using the raster calculator							      26

5	 CLIMATE DATA INTERPOLATION								        26
5.1	 Data resampling and interpolation								        26
5.2	 Differentiating between interpolation and downscaling						      30

ENDNOTES											           31

REFERENCES											           31



v

MANUAL

v

FIGURES

FIGURE 1  
Arab Domain (CORDEX- MENA Domain)									         1

FIGURE 2  
3 dimensional NetCDF array										          5

FIGURE 3 
List of Multidimension Tools in ArcMap									         6

FIGURE 4 
Make NetCDF Raster Layer tool										          7

FIGURE 5 
Raster Layer from NetCDF file										          7

FIGURE 6 
NetCDF Raster Layer properties										          8

FIGURE 7 
NetCDF Raster Layer zoomed in to shown gapped coastal areas							       8

FIGURE 8  
NetCDF time slice export tool in process									         9

FIGURE 9 
Model Builder: Add Make NetCDF Raster Layer									         10

FIGURE 10 
Model Builder: Iterate files										          10

FIGURE 11 
Model Builder: Create variable as folder									         10

FIGURE 12 
Enter data into Make NetCDF Raster Layer									         11

FIGURE 13
Model Builder: Perform process on all files in folder								        12

FIGURE 14
Model Builder: Add variable as workspace and create a geodatabase							       12

FIGURE 15
Model Builder: Clip NetCDF rasters to area of interest								        13

FIGURE 16  
Model Builder: Clip rasters										          13

FIGURE 17
Model Builder: Add clipped rasters to display									         14

FIGURE 18
Model Builder: Clip NetCDF rasters to area of interest result								       14

FIGURE 19
Multiband raster layer properties										          15

FIGURE 20
Multiband raster files in ArcCatalog										         15

FIGURE 21	
Grid system for nlat and nlon										          16

FIGURE 22 
Make NetCDF Table View tool										          17

FIGURE 23
Make NetCDF Table View result										          18



vi

TRAINING MANUAL ON THE USE OF GIS TO ANALYSE CLIMATE CHANGE DATA

vi

TABLE 1
Precipitation and temperature regional climate modelling outputs							       2

TABLE 2
Extreme temperature indices climate modelling outputs								        3

TABLE 3
Extreme precipitation indices climate modelling outputs								        4

TABLES

FIGURE 24
Model Builder: Make NetCDF Table View initial steps								        18

FIGURE 25 
Model Builder: Make NetCDF Table View entering data								        19

FIGURE 26  
Model Builder: Make NetCDF Table View Table to Table								        20

FIGURE 27 
Model Builder: Enter Table to Table information									         20

FIGURE 28 
Model Builder: View output in file folder and copy first table								        21

FIGURE 29 
Model Builder: Merge output into single table									         22

FIGURE 30  
Model Builder: Enter data into Append tool									         22

FIGURE 31 
Model Builder: Table to Excel tool										          23

FIGURE 32
Model Builder: Enter data into Table to Excel tool								        23

FIGURE 33
Model Builder: Make NetCDF Table View Excel output								        24

FIGURE 34
Cell Statistics tool											            25

FIGURE 35
Raster calculator											           26

FIGURE 36  
Resample tool											           26

FIGURE 37 
Option to activate Extensions in ArcMap									         27

FIGURE 38
Geostatistical Wizard tool										          28

FIGURE 39
Example of IDW interpolation result										         28

FIGURE 40
GA Layer to Grid tool											           29

FIGURE 41  
Extract by Mask tool											           29



vii

MANUAL

vii

ACRONYMS AND ABBREVIATIONS

ACSAD	 Arab Center for the Studies of Arid Zones and Dry Lands

CNRM-CM5	 Centre National de Recherches Météorologiques- Climate Model 5

CORDEX	 Coordinated Regional Climate Downscaling Experiment

CORDEX-MENA	 Coordinated Regional Climate Downscaling Experiment - Middle East North Africa

DJF		 December-January-February

EC-EARTH	 ECMWF-based Earth-system model

ESCWA	 United Nations Economic and Social Commission for Western Asia

ESGF	 Earth System Grid Federation

GCM	 global climate model or general circulation model

GFDL-ESM2M	 Geophysical Fluid Dynamics Laboratory-Earth System Model 2

GIS		 Geographic Information Systems

JJA 	 June-July-August

MAM	 March-April-May

mm		 millimetres

MNA22	 25-km resolution (MENA domain 0.22 degrees)

MNA44	 50-km resolution (MENA domain 0.44 degrees)

NetCDF	 Network Common Data Form

RCA4	 Rossby Centre Regional Atmospheric Model 4

RCM	 Regional Climate Model

RCP	 Representative Concentration Pathway

RICCAR	 Regional Initiative for the Assessment of Climate Change Impacts on Water Resources and Socio-Economic 		
		  Vulnerability in the Arab Region

RKH	 Regional Knowledge Hub

SMHI	 Swedish Meteorological and Hydrological Institute

SON	 September-October-November
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1	 INTRODUCTION

2	 SUMMARY OF RICCAR CLIMATE CHANGE DATA

The present training manual serves as a guide that describes how users can download and utilise climate data developed 
within the framework of the Regional Initiative for the Assessment of Climate Change Impacts on Water Resources and Socio-
Economic Vulnerability in the Arab Region (RICCAR). Although climate data can be used on different platforms for analysis, 
evaluation using Geographic Information Systems (GIS) tools from ESRI ArcMap is solely considered in this manual. 

Climate data outputs within the Arab Domain (figure 1) are described in the Arab Climate Change Assessment Report – Main 
Report. Data includes temperature, precipitation, and extreme events ensembles for three time periods (reference period, 
mid-century, and end-century), and according to two climate scenarios (RCP4.5 and RCP8.5). These ensembles were derived 
from bias-corrected regional climate modelling (RCM) outputs adapted from the Coordinated Regional Climate Downscaling 
Experiment (CORDEX). These outputs include modelled temperature and precipitation data from 1951-2100 with daily 
frequencies (table 1), and extreme events outputs from 1951-2100 with annual and seasonal frequencies (tables 2 and 3) for 
each of the studied driving global climate models (GCMs), namely CNRM-CM5, EC-EARTH, and GFDL-ESM2M. Results are 
available for different climate scenarios and at various spatial resolutions. Details regarding the modelling methodology can be 
found in the RICCAR Technical Note entitled Regional Climate Modelling and Regional Hydrological Modelling Applications in the 
Arab Region.1 

Climate modelling outputs are accessible online. Users can download the bias-corrected RCM outputs from the Regional 
Knowledge Hub (RKH) data portal.2 The raw RCM outputs (non-bias-corrected) adapted for RICCAR, other climate variables, 
and outputs from other domains can be obtained from CORDEX data available on the Earth System Grid Federation (ESGF) data 
portal.3 More information on CORDEX and the ESGF is described in a RICCAR technical note entitled Guidelines for Accessing 
CORDEX Regional Climate Projections.4 Users can obtain and use these datasets for institutional case studies and research. It is 
recommended to avoid mixing bias-corrected and raw RCM outputs.

MANUAL

Source: ESCWA  and others (2017). Arab  Climate  Change  Assessment  Report – Main Report., E/ESCWA/SDPD/2017/RICCAR/Report.

FIGURE 1: Arab Domain (CORDEX- MENA Domain)

71

1ARAB CLIMATE CHANGE ASSESSMENT REPORT - MAIN REPORT

 

Note: The boundary in orange represents the minimum domain configuration that would satisfy spatial criteria and served as the starting reference for comparison. The 
boundary in blue represents the eastward extension and the one in white the northward extension. The one in red represents extensions both east and north. The black boundary 
represents the domain used for previous studies supported by UNESCO.

Note: The Active domain (red) contains the area where RCM results are considered usable. The Full domain (blue) indicates the actual area needed for the RCM (RCA4 in this 
case) to perform properly within the active domain. The area between Active and Full domain is a transition zone between the GCM driving boundaries and the RCM: using 
results from this zone should be avoided.

Figure 3
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TABLE 1: Precipitation and temperature regional climate modelling outputs

Climate parameter Abbreviation Climate scenario Driving Global Climate 
Model (GCM) Data period Spatial resolution

Precipitation pr RCP2.6 EC-EARTH 1951-2100 50 x 50 km

Precipitation pr RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

Precipitation pr RCP4.5 EC-EARTH 1951-2100 50 x 50 km

Precipitation pr RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

Precipitation pr RCP8.5 EC-EARTH 1951-2100 25 x 25 km

Precipitation pr RCP8.5 GFDL-ESM2M 1951-2100 25 x 25 km

Precipitation pr RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

Precipitation pr RCP8.5 EC-EARTH 1951-2100 50 x 50 km

Precipitation pr RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

Temperature tas RCP2.6 EC-EARTH 1951-2100 50 x 50 km

Temperature tas RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

Temperature tas RCP4.5 EC-EARTH 1951-2100 50 x 50 km

Temperature tas RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

Temperature tas RCP8.5 EC-EARTH 1951-2100 25 x 25 km

Temperature tas RCP8.5 GFDL-ESM2M 1951-2100 25 x 25 km

Temperature tas RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

Temperature tas RCP8.5 EC-EARTH 1951-2100 50 x 50 km

Temperature tas RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

Maximum temperature tasmax RCP2.6 EC-EARTH 1951-2100 50 x 50 km

Maximum temperature tasmax RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

Maximum temperature tasmax RCP4.5 EC-EARTH 1951-2100 50 x 50 km

Maximum temperature tasmax RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

Maximum temperature tasmax RCP8.5 EC-EARTH 1951-2100 25 x 25 km

Maximum temperature tasmax RCP8.5 GFDL-ESM2M 1951-2100 25 x 25 km

Maximum temperature tasmax RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

Maximum temperature tasmax RCP8.5 EC-EARTH 1951-2100 50 x 50 km

Maximum temperature tasmax RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

Minimum temperature tasmin RCP2.6 EC-EARTH 1951-2100 50 x 50 km

Minimum temperature tasmin RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

Minimum temperature tasmin RCP4.5 EC-EARTH 1951-2100 50 x 50 km

Minimum temperature tasmin RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

Minimum temperature tasmin RCP8.5 EC-EARTH 1951-2100 25 x 25 km

Minimum temperature tasmin RCP8.5 GFDL-ESM2M 1951-2100 25 x 25 km

Minimum temperature tasmin RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

Minimum temperature tasmin RCP8.5 EC-EARTH 1951-2100 50 x 50 km

Minimum temperature tasmin RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km
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TABLE 2: Extreme temperature indices climate modelling outputs

Index Long name Climate scenario Driving Global Climate 
Model (GCM) Data period Spatial resolution

SU Number of summer days RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

SU Number of summer days RCP4.5 EC-EARTH 1951-2100 50 x 50 km

SU Number of summer days RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

SU Number of summer days RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

SU Number of summer days RCP8.5 EC-EARTH 1951-2100 50 x 50 km

SU Number of summer days RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

SU35 Number of hot days RCP2.6 EC-EARTH 1951-2100 50 x 50 km

SU35 Number of hot days RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

SU35 Number of hot days RCP4.5 EC-EARTH 1951-2100 50 x 50 km

SU35 Number of hot days RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

SU35 Number of hot days RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

SU35 Number of hot days RCP8.5 EC-EARTH 1951-2100 50 x 50 km

SU35 Number of hot days RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

SU40 Number of very hot days RCP2.6 EC-EARTH 1951-2100 50 x 50 km

SU40 Number of very hot days RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

SU40 Number of very hot days RCP4.5 EC-EARTH 1951-2100 50 x 50 km

SU40 Number of very hot days RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

SU40 Number of very hot days RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

SU40 Number of very hot days RCP8.5 EC-EARTH 1951-2100 50 x 50 km

SU40 Number of very hot days RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

TR Number of tropical nights RCP2.6 EC-EARTH 1951-2100 50 x 50 km

TR Number of tropical nights RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

TR Number of tropical nights RCP4.5 EC-EARTH 1951-2100 50 x 50 km

TR Number of tropical nights RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

TR Number of tropical nights RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

TR Number of tropical nights RCP8.5 EC-EARTH 1951-2100 50 x 50 km

TR Number of tropical nights RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km
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TABLE 3: Extreme precipitation indices climate modelling outputs

Index Long name Climate scenario Driving Global Climate 
Model (GCM) Data period Spatial resolution

CDD Maximum length of dry spell RCP2.6 EC-EARTH 1951-2100 50 x 50 km

CDD Maximum length of dry spell RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

CDD Maximum length of dry spell RCP4.5 EC-EARTH 1951-2100 50 x 50 km

CDD Maximum length of dry spell RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

CDD Maximum length of dry spell RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

CDD Maximum length of dry spell RCP8.5 EC-EARTH 1951-2100 50 x 50 km

CDD Maximum length of dry spell RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

CWD Maximum length of wet spell RCP2.6 EC-EARTH 1951-2100 50 x 50 km

CWD Maximum length of wet spell RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

CWD Maximum length of wet spell RCP4.5 EC-EARTH 1951-2100 50 x 50 km

CWD Maximum length of wet spell RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

CWD Maximum length of wet spell RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

CWD Maximum length of wet spell RCP8.5 EC-EARTH 1951-2100 50 x 50 km

CWD Maximum length of wet spell RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

R10 Count of 10 mm precipitation days RCP2.6 EC-EARTH 1951-2100 50 x 50 km

R10 Count of 10 mm precipitation days RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

R10 Count of 10 mm precipitation days RCP4.5 EC-EARTH 1951-2100 50 x 50 km

R10 Count of 10 mm precipitation days RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

R10 Count of 10 mm precipitation days RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

R10 Count of 10 mm precipitation days RCP8.5 EC-EARTH 1951-2100 50 x 50 km

R10 Count of 10 mm precipitation days RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

R20 Count of 20 mm precipitation days RCP2.6 EC-EARTH 1951-2100 50 x 50 km

R20 Count of 20 mm precipitation days RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

R20 Count of 20 mm precipitation days RCP4.5 EC-EARTH 1951-2100 50 x 50 km

R20 Count of 20 mm precipitation days RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

R20 Count of 20 mm precipitation days RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

R20 Count of 20 mm precipitation days RCP8.5 EC-EARTH 1951-2100 50 x 50 km

R20 Count of 20 mm precipitation days RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km

SDII Simple precipitation intensity index RCP2.6 EC-EARTH 1951-2100 50 x 50 km

SDII Simple precipitation intensity index RCP4.5 CNRM-CM5 1951-2100 50 x 50 km

SDII Simple precipitation intensity index RCP4.5 EC-EARTH 1951-2100 50 x 50 km

SDII Simple precipitation intensity index RCP4.5 GFDL-ESM2M 1951-2100 50 x 50 km

SDII Simple precipitation intensity index RCP8.5 CNRM-CM5 1951-2100 50 x 50 km

SDII Simple precipitation intensity index RCP8.5 EC-EARTH 1951-2100 50 x 50 km

SDII Simple precipitation intensity index RCP8.5 GFDL-ESM2M 1951-2100 50 x 50 km
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3	 ARCMAP MULTIDIMENSION TOOL

Regional climate modelling outputs are available in Network Common Data Form (NetCDF) format (.nc). NetCDF files enable 
storage of multidimensional datasets (figure 2). Each variable can be displayed through a dimension, such as time. They can be 
used on different software platforms, including MATLAB, Python, and R, but only ArcMap GIS will be discussed in the present 
training manual.  

The RICCAR Arab Domain climate data files have a naming convention similar to the following:

pr_MNA-44_CNRM-CERFACS-CNRM-CM5_historicalandrcp45_r1i1p1_SMHI-RCA4_v1-bc-dbs-wfdei_day_19510101-
21001231_2046_2046.nc

where: 

•	 pr is the climate variable
•	 MNA-44 is the CORDEX domain and spatial resolution
•	 CNRM-CERFACS-CNRM-CM5 is the global climate model
•	 historicalandrcp45 is the climate scenario
•	 r1i1p1 is the experimental ensemble calculation
•	 SMHI-RCA4 is the regional climate model
•	 v1-bc-dbs-wfdei is the bias-correction method
•	 day is the temporal resolution
•	 19510101-21001231 is the period of the entire dataset
•	 2046_2046 is the year of this NetCDF file.

Each file has 365 dimensions, representing each day of the year (for leap years, there are 366 dimensions).

3.1	 Introduction to NetCDF format

FIGURE 2: Three-dimensional NetCDF array
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For the extreme event indices, files are available both annually (ANN) or seasonally: DJF for December- January-February; MAM 
for March-April-May; JJA for June-July-August; and SON for September-October-November. Each file contains 150 dimensions, 
one for each year within the dataset. The file naming convention is described in the following example:

su35_MNA-44_ICHEC-EC-EARTH_rcp45_r12i1p1_SMHI-RCA4-DBS43-WFDEI-1980-2009_v1_day_1951-2100_SON.nc

where: 

•	 su35 is the climate variable
•	 MNA-44 is the CORDEX domain and spatial resolution,
•	 ICHEC-EC-EARTH is the global climate model
•	 rcp45 is the climate scenario
•	 r12i1p1 is the experimental ensemble calculation
•	 SMHI-RCA4 is the regional climate model
•	 DBS43-WFDEI-1980-2009_v1_day is the bias-correction method
•	 1951-2100 is the period of the dataset
•	 SON is the season represented.

3.2.1	Creating raster layer files

3.2	 Creating raster files from NetCDF files

NetCDF files cannot be added directly into ArcMap using the Add Data tool (     ). Instead, users must use a set of functions 
denoted as Multidimension Tools (figure 3).

To visualize NetCDF files in ArcMap, select Make NetCDF Raster Layer (figure 4). Choose the NetCDF file and using the drop-
down boxes, choose the relevant climate variable, X dimension, and Y dimension. The X- and Y-dimensions should be lon and 
lat, respectively, denoting longitude and latitude. This will direct the raster layer to be projected into a standardized coordinate 
system, facilitating a match with useful shapefiles, such as cities, country borders, and landmarks. For Output Raster Layer, 
users can leave the default name or designate a different file name.

The resultant raster layer in ArcMap (figure 5) will represent the first-time band in the NetCDF file, which will be 1 January for 
the temperature and precipitation files or the first year for each of the extreme events indices.

FIGURE 3: List of Multidimension Tools in ArcMap
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FIGURE 4: Make NetCDF Raster Layer tool

FIGURE 5: Raster Layer from NetCDF file
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To visualize other time bands, choose Layer Properties from the raster layer file in the Table of Contents. Select the tab denoted 
as NetCDF. There, users can see the different time bands available in the file and can choose one accordingly (figure 6).

It is worthy to note that the raster layer is only temporarily stored in the computer memory. Users can either save the raster layer 
or export the time band shown to a raster file by right-clicking on the file in the Table of Contents, and selecting Data > Export 
Data.

Users may notice that in cases of some coastal areas, no raster is shown (figure 7). This is because during the bias-correction 
process, grid cells which comprised less than 50 per cent as a water body were eliminated. To obtain RCM outputs at these 
locations, it is recommended to either select the nearest grid value or to extrapolate values (see section 5 of the present manual).

FIGURE 6: NetCDF Raster Layer properties

FIGURE 7: NetCDF Raster Layer zoomed in to shown gapped coastal areas
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Rather than exporting each individual time slice from NetCDF raster layers, a dedicated tool that automates the process  
is available for download5 from ESRI. Exporting multiple NetCDF files to rasters will help users to develop ensembles (see 
section 5 of the present manual).

When using the NetCDF time slice export tool, it is recommended to use a unique folder for each NetCDF file. By default, the 
individual time band rasters will be named Band_n, where n varies (figure 8). For temperature and precipitation NetCDF files, 
the numbers correspond to the day of the year according to a Gregorian calendar. For example, Band_1 represents 1 January, 
Band_2 represents 2 January, and Band_365 represents 31 December. The RICCAR NetCDF files do consider leap years, 
whereby every four years an extra calendar day is added. In such cases, Band_366 represents 31 December. For the extreme 
events indices, each of the bands represent a single year such that Band_1 is 1951 and Band_150 is 2100.

The model builder can help expedite creating raster layers from multiple NetCDF files, which can be clipped to a specific area of 
interest. The area of interest should be defined by a shapefile.

Begin by dragging the Make NetCDF Raster Layer tool over to the Model Builder (figure 9). The Model Builder will perform the 
same action multiple times by iteration. To do this, select Insert>Iterators>Files. To instruct the model to use the file as input, 
connect File to Make NetCDF Raster Layer. Then, right click on the File icon and select Rename. Add .nc to the File name to 
instruct the model to only select NetCDF files (figure 10). The NetCDF files should all be in a single folder (Note that the entire 
folder name, including parent folders, should be kept to a minimum otherwise there may be problems with running the model). 
Avoid mixing different climate parameters, GCMs, and RCPs to minimize confusion. Select Insert>Create Variable>Folder and 
connect the Folder icon to Iterate Files (figure 11).

FIGURE 8: NetCDF time slice export tool in process

3.2.2	Extracting multiple time slices from raster layer files

3.2.3	Using model builder to extract rasters for subareas of interest
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FIGURE 9: Model Builder: Add Make NetCDF Raster Layer

FIGURE 10: Model Builder: Iterate files

FIGURE 11: Model Builder: Create variable as folder
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FIGURE 12: Enter data into Make NetCDF Raster Layer

Double-click on the Folder icon and select the specific folder holding the NetCDF files. Icon elements in the model will then 
change to coloured, indicating that the model step is set up correctly. The Make NetCDF Raster Layer and Output Raster Layer 
icons remain blank because those elements have not been set up yet.

Double-click on the Make NetCDF Raster Layer icon. The default will show File.nc for Input NetCDF File and the only available 
variable will be called Name. To set up the tool correctly, select the first NetCDF file from the folder that will be modelled, along 
with the variables, just as would be done to create a single raster file. The Output Raster Layer name can be left as the default. 
Under Band Dimension, time should be selected to instruct the model to create a multiband raster layer (figure 12).

A blue oval indicating at the NetCDF file will overlap the green oval for File.nc. The blue oval is now considered unneeded input 
and can simply be deleted (the Make NetCDF Raster Layer and Output Raster Layer icons will change back to white).  Double-
click on the Make NetCDF Raster Layer icon and confirm that the variable and x- and y-dimensions are correct.
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Connect File.nc to Make NetCDF Raster Layer to instruct the model to perform the function on all NetCDF files in the selected 
folder (figure 13). 

At this point, run the model to confirm is it is operating correctly.

To visualize the output, select Insert>Create Variable>Workspace. Double-click on workspace and create a new geodatabase 
(.gdb) in the working folder. In this example, the geodatabase is named Temp_RCP4.5_CNRM-CM5.gdb (figure 14). 

FIGURE 13: Model Builder: Perform process on all files in folder

FIGURE 14: Model Builder: Add variable as workspace and create a geodatabase
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It is not necessary at this point to connect the blue geodatabase oval to the rest of the model elements.

The final step is to clip the NetCDF raster files. Add the Clip tool to the model found under Data Management 
Tools>Raster>Raster Processing and connect it to the raster layer output (green oval) (figure 15).

Double-click on the Clip icon. Under Output Extent, select the shapefile for the area of interest. The box for Use Input Features 
for Clipping Geometry should be selected. Under Output Raster Dataset, select the geodatabase created (for this example, 
Temp_RCP4.5_CNRM-CM5.gdb) and name the output (i.e. %Name%). This naming convention will name the files the same 
way as the original NetCDF files. For this to function, the original NetCDF files in the folder should have names of less than 13 
characters, such as tas_2000, tas_2001, etc, representing the climate variable and year (figure 16).

FIGURE 15: Model Builder: Clip NetCDF rasters to area of interest

FIGURE 16: Model Builder: Clip rasters
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Right-click on the output icon and select Add to Display to view the raster files in ArcMap (figure 17). Run the model.

The result will be one multiband raster file for each of the NetCDF files, clipped to the area of interest, which in this 
example is a box around Egypt (figure 18). By default, the first three-time bands are divided into three colour bands. 
Properties for each of the time bands can be viewed by right-clicking on the layer file in the Table of Contents and 
selecting Layer Properties (figure 19). Details for each of the time bands, including a preview of the individual raster 
band, can be obtained from the ArcCatalog (figure 20).

FIGURE 17: Model Builder: Add clipped rasters to display

FIGURE 18: Model Builder: Clip NetCDF rasters to area of interest result
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FIGURE 19: Multiband raster layer properties

FIGURE 20: Multiband raster files in ArcCatalog
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3.3.1	 Introduction to nlon and nlat

3.3	 Creating tables from NetCDF files

When creating raster files from NetCDF files, it is recommended to work in standard cartesian coordinates, designated as 
lon (longitude) and lat (latitude). When creating tabular data from the MNA-44 domain (50 x 50 km), users must work in nlon 
and nlat. In the case of nlat and nlon, coordinates are determined by the number of grid cells in the vertical and horizontal 
directions, respectively, originating at the bottom left corner (figure 21).

For the MNA-44 domain (50 x 50 km), there are 232 horizontal cells and 118 vertical cells. For the MNA-22 domain (25 x 25 km),  
the number of cells doubles owing to the finer resolution, resulting in 464 horizontal cells and 236 vertical cells. For other 
domains, the number of cells will depend on the size of the domain and the spatial resolution.

Users can convert coordinates from conventional to nlon and nlat using equations 1 and 2 for MNA-44 and equations 3 and 4  
for MNA-22.

Round the resultant nlon and nlat values to the nearest integer value, as the cell values are also integers. Smaller domains would likely 
require adjustments to the equations.

(1)

(2)

(3)

(4)

FIGURE 21: Grid system for nlat and nlon
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3.3.2	Creating table of climate data for a given location

The Make NetCDF Table View tool found under the Multidimension Tools can generate a table of all values from a NetCDF file at 
a single location. Upon opening the tool, select the appropriate NetCDF file, select the applicable climate variable, enter time 
under row dimensions, and select nlon and nlat for the dimension values. Enter the appropriate nlon and nlat coordinates for the 
selected location (figure 22). In the example, Tunis is selected. Note that MNA-22 (25 x 25 km) data does not include nlon and 
nlat; instead, users select conventional longitude and latitude coordinates based on the centroid of the grid pixel. Shapefiles to 
help users determine nlon and nlat coordinates (for MNA-44) and centroid longitude and latitude coordinates (for MNA-22) are 
available upon request.

FIGURE 22: Make NetCDF Table View tool
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The result will generate a table of values for a specified location (figure 23). Note the temporal resolution of the NetCDF file to 
obtain the correct units of measurement for the climate variable. For example, since precipitation is daily data, the resultant 
table values are in mm/day. Similarly, for seasonal extreme climate indices, units are days/season/year.

FIGURE 23: Make NetCDF Table View result

FIGURE 24: Model Builder: Make NetCDF Table View initial steps

3.3.3	Using the model builder to create a climate data table for multiple years

The Model Builder can be used to create a table containing values for a given climate parameter at a single point over multiple 
years, such as 1980-2100. The initial steps are identical as the ones to create multiple clipped rasters, except that the tool to 
use is Make NetCDF Table View (figure 24).
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In this example, precipitation data for Amman is evaluated. The location coordinates must be converted to nlon and nlat. Enter 
the information in the Make NetCDF Table View tool using one of the NetCDF files from the folder (figure 25). Remember to 
delete the blue oval representing the NetCDF file and connect the green File.nc oval to the tool. Next, run the model.

Add the Table to Table tool to the Model Builder found under Conversion Tools>To Geodatabase (figure 26). This will convert the 
output file from Make NetCDF Table View to a geodatabase. 

Double-click on the Table to Table icon to enter information.  The Input Rows should be the output from Make NetCDF Table 
View, which is called File View in this example. The Output Location will be a folder specified by the user. The Output Table 
should be named by the user and include %n% to add a unique number to each table, starting from 0 (figure 27).

FIGURE 25: Model Builder: Make NetCDF Table View entering data
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FIGURE 26: Model Builder: Make NetCDF Table View Table to Table

FIGURE 27: Model Builder: Enter Table to Table information
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Run the entire model. After completion, the user can open up the folder that was created. Three files (cpg, .dbf, and .dbf.xml) 
comprise a single table. Copy and paste the first table (all 3 files), which is the output table name followed by 0 (figure 28).

To merge all the results into a single table, the Append tool must be added to the Model Builder, found under Data Management 
Tools>General.  Connect to the Table to Table output (i.e. precip_%n%.dbf) (figure 29).

Double-click on the Append tool. The Input Dataset will be automatically entered by the connection in the Model Builder (i.e. 
precip_%n%.dbf). Select the copied .dbf file (i.e. precip_0-Copy.dbf) from the output folder saved to the computer and add it to 
the Target Dataset (figure 30).

FIGURE 28: Model Builder: View output in file folder and copy first table
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FIGURE 29: Model Builder: Merge output into single table

FIGURE 30: Model Builder: Enter data into Append tool
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Add the Table to Excel tool to the Model Builder found under Conversion Tools > Excel and connect to the output to consolidate 
all files into Excel format (figure 31).

Double-click on the Table to Excel tool. The Input Table will be the default from the Model Builder. Users will need to specify an 
output location and file name, keeping the .xls extension for an Excel file (figure 32).

FIGURE 31: Model Builder: Table to Excel tool

FIGURE 32: Model Builder: Enter data into Table to Excel tool
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Save and run the entire model. The result will be an Excel spreadsheet containing daily precipitation values (in mm/day) for 
each NetCDF file at the selected location (figure 33).

FIGURE 33: Model Builder: Make NetCDF Table View Excel output
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4	 CREATING ENSEMBLES USING SPATIAL ANALYST TOOLS

To derive the best possible projected estimate from the different climate models, ensemble analysis is recommended. All 
model simulations based on the same climate scenario and which have the same spatial resolution are grouped and presented 
as an ensemble mean. Moreover, the ensemble mean should represent results from several years. For RICCAR, three different 
time periods were selected to present data as an ensemble mean:

•	 Reference period, representing 1986-2005
•	 Mid-century, representing 2046-2065
•	 End-century, representing 2081-2100.

Outputs from these time periods are available on the RKH data portal in addition to the near-century data, representing 
2016-2035.

Users may elect to evaluate different periods, such as 10-year climate projections, or may wish to evaluate data seasonally. 
These cases require developing an ensemble.

The first steps are to create a NetCDF raster file (see section 3.2.1) and to extract multiple time slices from the raster layer file 
(see section 3.2.2).

The Cell Statistics tool, found under Spatial Analyst Tools > Local, can calculate the sum, mean, or other statistics from multiple 
raster files (figure 34). 

The default statistic is mean. This is typically used for climate parameters such as temperature. However, for precipitation, 
typically average annual values are reported as mm/month or mm/year instead of mm/day. In these cases, users must first sum 
each of the daily raster bands, and then average the summed values. Users may find it helpful to create a model using Model 
Builder to expedite this process and minimize errors in selecting the relevant time bands.

The Cell Statistics tool is repeated to average results obtained from multiple years, and then again to average results from each 
of the climate models, to finally obtain the ensemble result.

4.1	 Calculating annual and seasonal projections

FIGURE 34: Cell Statistics tool
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Rather than report actual values obtained from future projections, it is common to report the change in values compared with 
a designated reference period. For example, for RICCAR, mid-century (2046-2065) results reflected a change in the different 
climate parameters compared to the reference period (1986-2005).

Change in values can be determined by using the Raster Calculator, found under Spatial Analyst Tools > Math Algebra 
(figure 35). The Raster Calculator can perform many mathematical functions. In this case, users simply subtract the reference 
period values from the projected values.

4.2	 Comparing projections using the raster calculator

FIGURE 35: Raster calculator

FIGURE 36: Resample tool

5	 CLIMATE DATA INTERPOLATION

As previously described, the climate data spatial resolution is 50 x 50 km (or in limited cases, 25 x 25 km). In addition, data 
is gapped in some coastal areas due to the bias-correction process. Users may elect to change the data to a different spatial 
resolution to allow for easier compatibility with other raster files or to extrapolate values to include coastal areas. 

The Resample tool, found under Data Management Tools > Raster > Raster Processing, enables users to convert rasters to a 
different spatial resolution (figure 36). By default, the 50 x 50 km climate data will appear with a grid cell size of 0.44 x 0.44, 
representing degrees (similarly, the 25 x 25 km data will show 0.22 x 0.22 degrees).

5.1	 Data resampling and interpolation
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To convert 50 x 50 km to 1 x 1 km, equation 5 needs to be used, which divides the size in degrees by the size in kilometres, 
where x = 1 km. A similar approach should be applied for differing grid cell sizes.

There are four different resampling techniques to select from: nearest, majority, bilinear, and cubic. The first two are best suited 
for discrete data that have distinct boundaries or limits such as building or roadway data. The last two are suited for continuous 
data, such as climate data. The bilinear method averages values from the surrounding four pixels, whereas the cubic method 
averages from the nearest 16 pixels and results in a smoother image. 

Resampling changes only the grid square size with some smoothing. The data extent is the same as the original dataset. In 
some cases, users may elect to extrapolate data to areas that may be gapped, such as coastal areas. This is performed using a 
multistep process:

1.	 Conduct interpolation using Geostatistical Analyst
2.	 Convert interpolated result to raster
3.	 Extract raster to desired shape.

Interpolation tools can be found under the Geostatistical Analyst and Spatial Analyst Tools > Interpolation. The latter will 
not work for raster data. To use Geostatistical Analyst, the applicable extension must be turned on, found under Customize 
in ArcMap (figure 37). The Geostatistical Analyst toolbar can then be activated. Interpolation can be facilitated using the 
Geostatistical Wizard (figure 38). 

Multiple interpolation methods are available for use. Inverse Distance Weighting (IDW) is fastest and most appropriate because 
the data is continuous. Users can then either select “Finish” directly or view the intermediate interpolation steps by pressing 
“Next”. A review of intermediate results is needed when applying more advanced interpolation methods, such as kriging. The 
interpolated result using IDW will resemble figure 39 comprising climate data for the entire domain including water bodies. Note 
that this interpolated result is not saved and is solely available in the computer memory.

FIGURE 37: Option to activate Extensions in ArcMap
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FIGURE 38: Geostatistical Wizard tool

FIGURE 39: Example of IDW interpolation result
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FIGURE 40: GA Layer to Grid tool

FIGURE 41: Extract by Mask tool

The interpolated result must be converted to raster by using the GA Layer to Grid tool (figure 40). This tool is activated by 
right clicking on the Inverse Distance Weighting layer in the Table of Contents, selecting Data, and Export to Raster. It is 
recommended to leave the default name as the Output surface raster; otherwise, users may encounter errors using the tool. 
The output cell size should be the same as the resampled cell size. The number of horizontal and vertical points in the cell is 1, 
which should be the default value. The result will be shown in the Table of Contents.

The GA Layer to Grid raster can be cut to a desired shape (i.e. watershed, country border) using the Extract by Mask tool, found 
under Spatial Analyst Tools/Extraction (figure 41). Select the GA Layer to Grid raster and the desired shape (either a raster 
or a shapefile). Users may find extraneous data with the result or may encounter errors naming the output raster something 
other than the default. In such cases, the extraneous data can be removed, or the file renamed and saved using the Extract by 
Rectangle tool. The result will be a raster dataset with the desired grid cell size and extent.

Note that interpolation cannot be done using the Fill tool, found under Spatial Analyst Tools > Hydrology. This tool is intended to 
remove small imperfections in raster datasets for hydrological applications. It will not sufficiently extrapolate data. 

These processes should only be applied in certain cases, such as vulnerability studies, whereby contributing datasets should be 
of the same spatial resolution and extent. It is not intended to imply a finer spatial resolution or accuracy of data.
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Regional climate modelling provides smaller scale projections than what is traditionally available through global climate 
models.  Regional climate models can account for details, such as topography, and simulate the climate in greater spatial detail 
than global climate models. However, the scale of the projection determines its suitability and accuracy for use in different 
studies.  For smaller scale analysis, users may be tempted to resample and extrapolate data as described in section 5.1 of the 
present manual. However, interpolation methods such as kriging (or co-kriging) should not be used with modelled climate data, 
such as reanalysis data or projections. Kriging can be applied when interpolating historical meteorological data as these are 
observed datasets. Further information can be found in Venäläinen and Heikinheimo (2002), Jeffrey and others (2001), and 
Spadavecchia and Williams (2009), and others.

To correctly convert climate modelling outputs to a smaller spatial or temporal scale, users must perform downscaling. 
Downscaling can be pursued through dynamic or statistical techniques. Dynamic downscaling runs a regional climate 
model over a sub-domain using observational datasets and draws on other climate modelling outputs to prescribe boundary 
conditions based on physical principles. This method can be considered computationally intensive. Statistical downscaling 
considers the statistical relationships between local climate variables and large-scale predictors such as pressure fields 
coupled with the application of these relationships to modelling outputs. For more information, refer to Teutschbein and 
Seibert (2010).

5.2	 Differentiating between interpolation and downscaling
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